X-osadminの自留地
  • 博客主页 HomePage
  • 技术小絮 Tech
  • 软件专题 Softs
    • proxmox
    • openwrt
    • chromebook
    • Zerotier
    • 虚拟化
  • 友情链接 Following

xosadmin

BGPlayer / Codes learner / Love Linux
Posts
73
Comments
0

友情链接 – Friendly Links

  • Add your site here…
xosadmin
7 years ago

树莓派安装ffmpeg

近日想尝试传输自己的流式媒体。目前测试了Hyper-V虚拟机,效果并不理想。原因是Hyper-V太吃资源。后来,测试在Hyper-V虚拟机下安装Linux系统进行推流,由于是yum安装的ffmpeg,年代有点过于久远,并且编译安装比较慢。于是,经过一系列资料的搜索,我便在Hyper-V上搭建了rtmp服务器,并选择利用树莓派的硬件视频解码器作为推流服务器(在同一内网下)。话不多说,开干~

1.安装Raspbian系统,这里选择的是无桌面环境的Raspbian

2. 编译安装x264解码器,代码为:

git clone git://git.videolan.org/x264.git
cd x264
./configure –host=arm-unknown-linux-gnueabi –enable-static –disable-opencl –enable-shared
make && make install

3. 开始编译安装ffmpeg,代码为:

wget http://ffmpeg.org/releases/ffmpeg-4.2.1.tar.gz

tar -xvf ffmpeg-4.2.1.tar.gz

cd ffmpeg-*

./configure –arch=armel –target-os=linux –enable-gpl –enable-libx264 –enable-nonfree

make && make install

4. 安装一点点依赖,代码为:

apt-get install libsdl2-dev -y

5. 经过一篇知乎文章的启发,再完成一下ldconfig的配置,代码如下:

echo “/usr/local/lib” >> /etc/ld.so.conf

ldconfig

6. 在命令行中输入ffmpeg,查看是否有输出,有输出则为成功

7. Enjoy~

 

文章参考:

https://zhuanlan.zhihu.com/p/36311427

https://blog.csdn.net/u011636440/article/details/80294235

  • 技术小絮
等 人表示很赞
2,953
0

📮Comments

No Comment.
xosadmin
xosadmin
6 years ago
推荐 apache提示You don’t have permission to access /* on this server.的解决方法
首先,X-osadmin在这里祝大家520快乐!近日有朋友遇到了这样一个问题:在CentOS 8下安装php-fpm+apache,在浏览器打开时均提示You don’t have permission to access / ...
  • 技术小絮
3,891 0
xosadmin
xosadmin
3 years ago
推荐 Fail2ban无法启动的解决方法
在启动fail2ban时,有时会发生错误,具体错误如下: ERROR Failed during configuration: Have not found any log file for sshd jail ERROR Async co ...
  • 技术小絮
526 0
xosadmin
xosadmin
6 years ago
推荐 Debian提示Malformed Description-md5的解决方法
近日,有一台vps在执行apt update时,报出以下错误,并返回错误值100。错误代码如下: E: Malformed Description-md5 line; doesn’t have the required leng ...
  • 技术小絮
1,731 0
xosadmin
xosadmin
5 years ago
推荐 为proxmox 6/7一键开启bbr
新版Proxmox 6/7基于debian buster/bullseye操作系统,已采用5.10以上内核,因此符合免更换内核开启bbr的条件。只需要按照以下操作进行操作即可: echo “net.core.default_qd ...
  • proxmox
  • 技术小絮
1,390 0
xosadmin
xosadmin
8 years ago
推荐 CentOS下如何搭建Linux发行版镜像站
最近正在忙活着搭建云鼎Linux镜像站。因为有很多朋友很想要一个这样的网站,并且在问如何搭建这类的网站。因此,X-osadmin为大家讲讲如何搭建。 废话不多说,进入正题~   一、环境准备 操作系统:CentOS 6.9 X8 ...
  • 技术小絮
2,523 0
  • Proxmox强制删除离线集群节点方法
  • PVE Cluster给node更换corosync IP的方法
  • HPE Microserver系列降低噪音的一种办法
  • Debian 13 Trixie安装Proxmox VE
  • Windows FTP服务器通过PASV模式无法获取目录的解决方法
  • Proxmox日志出现大量lxcfs truncated错误的解决方案

文章聚合

  • Proxmox强制删除离线集群节点方法
  • PVE Cluster给node更换corosync IP的方法
  • Debian 13 Trixie安装Proxmox VE
  • Proxmox日志出现大量lxcfs truncated错误的解决方案
  • Proxmox通过CLI向LXC挂载已有虚拟磁盘的方法
  • Proxmox VE通过全盘方式直通硬盘

Multilangual Translator

Copyright © 2016-2026 X-osadminの自留地. All rights reserved. 萌ICP备20258855号
  • 博客主页 HomePage
  • 技术小絮 Tech
  • 软件专题 Softs
    • proxmox
    • openwrt
    • chromebook
    • Zerotier
    • 虚拟化
  • 友情链接 Following
Welcome
Forgot password?
Welcome
Forgot password?
Social Login
Login with WeChat QR Code
Unregistered WeChat IDs will be automatically used to create an account.
Scan and Reply with Keywords「登录」Get Verification Code
Social Login
Free registration
Social Login
Reset password
Back to Login