X-osadminの自留地
  • 博客主页 HomePage
  • 技术小絮 Tech
  • 软件专题 Softs
    • proxmox
    • openwrt
    • chromebook
    • Zerotier
    • 虚拟化
  • 友情链接 Following

xosadmin

BGPlayer / Codes learner / Love Linux
Posts
73
Comments
0

友情链接 – Friendly Links

  • Add your site here…
xosadmin
6 years ago

Proxmox “QEMU version ‘x.x.x’ is too old”问题的解决方法

最近在Proxmox操作时发现,由于集群中有一台服务器的Proxmox安装时间较早,因故在迁移虚拟机到该服务器时遇到了这样一个错误:Installed QEMU version ‘x.x.x’ is too old to run machine type ‘pc-q35-5.0+pve0’。具体迁移报错日志摘录如下:

操作目标:将VM 101从promoxserver1 (10.1.1.2)在线迁移至proxmoxserver2 (10.1.1.1)。

Task viewer: VM 101 – Migrate
2020-05-14 23:10:46 starting migration of VM 101 to node ‘proxmoxserver2’ (10.1.1.1)
2020-05-14 23:10:47 found local disk ‘proxmoxserver1:101/vm-101-disk-0.qcow2’ (in current VM config)
2020-05-14 23:10:47 copying local disk images
2020-05-14 23:10:47 starting VM 101 on remote node ‘proxmoxserver2’
2020-05-14 23:10:48 [proxmoxserver2] Installed QEMU version ‘4.1.1’ is too old to run machine type ‘pc-q35-5.0+pve0’, please upgrade node ‘proxmoxserver2’
2020-05-14 23:10:48 ERROR: online migrate failure – remote command failed with exit code 255
2020-05-14 23:10:48 aborting phase 2 – cleanup resources
2020-05-14 23:10:48 migrate_cancel
2020-05-14 23:10:49 ERROR: migration finished with problems (duration 00:00:03)
TASK ERROR: migration problems

起初,X-osadmin尝试将该虚拟机的机型更换成i440fx,问题依旧。于是经过日志分析和资料查找,采用如下解决方案:

在迁移目标机器上执行:apt dist-upgrade

完成后重启该服务器,问题解决!

  • proxmox
  • 技术小絮
等 人表示很赞
3,285
0

📮Comments

No Comment.
xosadmin
xosadmin
5 years ago
推荐 CentOS迁移后开机提示lvm not found的解决方法
最近在尝试将Hyper-V虚拟机迁移至proxmox VE。在经过QEMU-IMG转换完后,部分虚拟机出现了无法启动的问题,并提示:/dev/centos/root not found,terminal卡在dracut。这是由于initra ...
  • proxmox
  • 技术小絮
1,314 0
xosadmin
xosadmin
3 years ago
推荐 Fail2ban无法启动的解决方法
在启动fail2ban时,有时会发生错误,具体错误如下: ERROR Failed during configuration: Have not found any log file for sshd jail ERROR Async co ...
  • 技术小絮
525 0
xosadmin
xosadmin
2 years ago
推荐 Windows FTP服务器通过PASV模式无法获取目录的解决方法
Windows FTP Server是一个Windows IIS自带的FTP服务器。在搭建后可能会出现通过PASV模式无法获得目录列表的问题。具体解决方法如下: 在Server Manager中安装FTP Extensions (若已安装 ...
  • 技术小絮
383 0
xosadmin
xosadmin
8 years ago
推荐 CentOS下如何搭建Linux发行版镜像站
最近正在忙活着搭建云鼎Linux镜像站。因为有很多朋友很想要一个这样的网站,并且在问如何搭建这类的网站。因此,X-osadmin为大家讲讲如何搭建。 废话不多说,进入正题~   一、环境准备 操作系统:CentOS 6.9 X8 ...
  • 技术小絮
2,523 0
xosadmin
xosadmin
5 years ago
推荐 Debian 11启用rc.local方法
rc.local是一个令大家耳熟详的文件,它在Redhat系列操作系统中可以让用户添加自定义开机脚本并运行。但是在Debian 11操作系统中,这个功能不被默认开启。这篇文章将介绍如何开启rc.local。话不多说,开始~ 先通过以下命令 ...
  • 技术小絮
2,998 0
  • Proxmox强制删除离线集群节点方法
  • PVE Cluster给node更换corosync IP的方法
  • HPE Microserver系列降低噪音的一种办法
  • Debian 13 Trixie安装Proxmox VE
  • Windows FTP服务器通过PASV模式无法获取目录的解决方法
  • Proxmox日志出现大量lxcfs truncated错误的解决方案

文章聚合

  • Proxmox强制删除离线集群节点方法
  • PVE Cluster给node更换corosync IP的方法
  • Debian 13 Trixie安装Proxmox VE
  • Proxmox日志出现大量lxcfs truncated错误的解决方案
  • Proxmox通过CLI向LXC挂载已有虚拟磁盘的方法
  • Proxmox VE通过全盘方式直通硬盘

Multilangual Translator

Copyright © 2016-2026 X-osadminの自留地. All rights reserved. 萌ICP备20258855号
  • 博客主页 HomePage
  • 技术小絮 Tech
  • 软件专题 Softs
    • proxmox
    • openwrt
    • chromebook
    • Zerotier
    • 虚拟化
  • 友情链接 Following
Welcome
Forgot password?
Welcome
Forgot password?
Social Login
Login with WeChat QR Code
Unregistered WeChat IDs will be automatically used to create an account.
Scan and Reply with Keywords「登录」Get Verification Code
Social Login
Free registration
Social Login
Reset password
Back to Login